UAD Plug-Ins

Welcome to UA Support
How can we help?

Mac Pro (Late 2013) compatibility with Apollo X Series Interfaces

The latest generation of Apple Mac Pro computers (Late 2013 “black cylinder” models) are compatible with all Apollo X Series audio interfaces when using the latest UAD software.

  • The latest UAD software is available here. The latest UAD software is compatible with all UA audio interfaces and UAD-2 DSP accelerators.

  • Mac Pro (Late 2013) computers require UAD v9.6.1 Build 62772 or higher. The build number can be found in the System Info panel within the UAD Meter & Control Panel application, as shown in the screenshot below.

uad-meter-build-62772.pngApollo X with Mac Pro (Late 2013) models require build number 62772 or higher

Have more questions? Submit a request

Comments