UAD Plug-Ins

Welcome to UA Support
How can we help?

UAD-2 Satellite FireWire System Requirements

UAD Powered Plug-Ins version 9.4

  • Windows 7, 8.1, or 10 (64-Bit Editions)
  • macOS 10.10 Yosemite, 10.11 El Capitan, 10.12 Sierra, 10.13 High Sierra
  • Available FireWire 800 port*
  • 6 gigabytes available storage
  • Internet connection to download software and authorize UAD plug-ins
  • Compatible VST, Audio Units, RTAS, or AAX 64 plug-in host DAW software

*On Windows FireWire systems, a qualified PCIe-to-FireWire adapter card is required.
See the UAD-2 Satellite FireWire Windows Compatibility article for details. 

Notes 

  • Operating systems not listed above are untested. Although untested operating systems may work, they are not supported by Universal Audio. Prior UAD software for older operating systems and discontinued UAD products is available in the UAD software archives
  • Pre-release and beta versions of operating systems are not supported.
  • For details on macOS 10.13 High Sierra and Windows 10 Fall Creator's Update compatibility, click here.

 

Have more questions? Submit a request

Comments